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No body text in email sent to Synergist

Dave Harvey -

Issue: 

Email is getting to Synergist successfully, but there is no text in the body of the message.

Error message: 

None

Symptoms: 

No body text in emails sent to Synergist. Only header and subject text is received.

Cause:

Your mail server is removing the plain text equivalent part of the message.

Synergist requires that email messages are formatted in plain text. Email is normally sent and received by mail servers in two parts (unless sent as text only). There is the html or rtf formatted message, which is usually accompanied by a plain text equivalent. Normally the plain text equivalent of an email message is never seen – email clients such as Outlook generally ignore it and display the html (or other formatted) message instead.  Sometimes only the plain text version is sent (usually because the sending email client is configured to send only plain text); this is normally the only time you see plain text email in your email client – when there is no html message to display.

Resolution: 

A change may need to be made on your mail server. For MS Exchange for example, that would mean setting the POP and IMAP client retrieval format (Server configuration > Client access > POP3 and IMAP4) to  'Html and alternative text' (the email client will decide which version to present for a mixture of formats). The default setting is 'best body'. The mailbox used by Synergist should be set to 'plain text'. If your internal mail system involves more than one mail server, these servers will need to be configured the same way. The POP3/IMAP4 service will need to be restarted after any changes.

This is Exchange 2010, for example:

 

 Office365 Hosted email:

Client access may have to be adjusted via Powershell for the mailbox used for email integration, in addition to ensuring the above is true.

If using IMAP for message retrieval:

Set-CASMailbox -Identity synergist -ImapMessagesRetrievalMimeFormat TextOnly

Set-CASMailbox -Identity synergist -ImapUseProtocolDefaults $false

If using POP for message retrieval:

Set-CASMailbox -Identity synergist -PopMessagesRetrievalMimeFormat TextOnly

Set-CASMailbox -Identity synergist -PopUseProtocolDefaults $false

Check these settings by using:

Get-CASMailbox -Identity synergist | Format-List Imap*

Get-CASMailbox -Identity synergist | Format-List Pop*

More information can be found on this at https://technet.microsoft.com/en-us/library/bb125264(v=exchg.160).aspx

Information on setting up a connection to to Office 365 via Powershell can be found at https://technet.microsoft.com/library/dn568015.aspx

 

Other notes:

Note that "best body" format used to contain a plain text body, but since Exchange 2007 SP 3 Update Rollup 1 this behaviour changed such that a plain text body is not included:

http://technet.microsoft.com/en-us/library/gg491244(v=exchg.80).aspx

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